今天偶然发现博客的php还是5.4的老版本,之前忘记升级了。
切换版本时提示:切换php版本问题:设置失败,没有在网站配置文件中找到enable-php-xx相关配置项!

解决办法

问题出在:/www/server/panel/vhost/openlitespeed中有不完整的网站配置文件,将“openlitespeed”文件夹删除即可,这个是软件卸载残留,删除不影响使用。

如果不知道网站php版本可在网站根目录新建名为phpinfo.php文件,输入以下代码

<?php
echo phpinfo();
?>

随后访问即可。
例如:
"https://xxxxxx/phpinfo.php"

星空社区同步更新